INFOS SUPPLEMENTAIRES
Linux AMD64: Dossier archive des pilotes

LIENS CORRESPONDANTS
Linux Discussion Forum
For an external resource on Linux topics, visit the discussion forum at nvnews.net

Produits supportés (Linux)

 Linux x64 (AMD64/EM64T) Display Driver

Version: 180.44
Système d’exploitation: Linux x64 (AMD64/EM64T)
Date de rélisation: 30.03.2009

Principales caractéristiques de cette version

  • Ajout de la prise en charge des nouveaux GPU suivants :
    • Quadro FX 3800
    • Quadro FX 3700M
    • Quadro FX 1800
    • Quadro FX 580
    • Quadro FX 380
    • Quadro NVS 295
    • GeForce GT 120
    • GeForce G100
  • Correction d’un problème entraînant parfois des erreurs Xid et des corruptions d’affichage lors de l’utilisation d’OpenGL en mode de rendu pour fenêtres redirigées (exemple : quand Java2D est utilisé avec l’option "Dsun.java2d.opengl=true").
  • Mise à jour de la commande "glGetStringi(GL_EXTENSIONS, i)", qui renvoyait la valeur "NULL" dans les contextes d’aperçu d’OpenGL 3.0.
  • Correction de problèmes d’OpenGL lors de l’utilisation du Plasma de KDE4.
  • Correction de problèmes d’OpenGL lors de l’exécution d’un grand nombre d’objets texturés.
  • Correction du rapport d’estampille temporelle de l’extension "GL_NV_present_video" dans SDI II avec les GPU Quadro FX 4800 et 5800.
  • Amélioration du support de la gestion énergétique sur certains systèmes, comme les stations de travail Hewlett-Packard xw4600.
  • Correction d’un problème entraînant des blocages temporaires de l’écran lors de la sortie inopinée des applications OpenGL sur les GPU GeForce des séries 6 et 7.
  • Correction d’un problème de crash du serveur X lors de la tentative du client X de modéliser des formes trapézoïdales lors de la désactivation de RenderAccel.
  • Amélioration de la récupération consécutive à certains types d’erreurs.
  • Correction d’un bug entraînant un blocage d’Autodesk Maya lors de l’activation de la routine d’Overlay.
  • Correction d’un problème d’interaction entre OpenGL et les librairies de suivi de mémoire comme MicroQuill SmartHeap.
  • Intégration du support des tampons de rendu RG avec OpenGL 3.0.
  • Intégration du support des tampons de profondeur en virgule flottante avec OpenGL 3.0.
  • Correction d’un problème entraînant un crash de Valgrind lors du traçage des programmes utilisant OpenGL.
  • Mise à jour de VDPAU pour inclure le support de l’accélération VC-1/WMV sur tous les GPU supportés par VDPAU (voir le fichier LisezMoi pour plus de détails).
  • Correction d’une corruption de VDPAU avec certains clips vidéo H.264.
  • Mise à jour de la documentation de VDPAU (fichiers LisezMoi et vdpau.h), notamment vis-à-vis de l’utilisation des algorithmes de désentrelacement de l’objet VdpVideoMixer. Mise à jour de la documentation relative au désentrelacement dit de "half rate", qui devrait normalement permettre une compatibilité des algorithmes avancés sur les systèmes les moins performants.
  • Intégration d’une option "skip chroma deinterlace" dans VDPAU, qui devrait normalement permettre une compatibilité des algorithmes de désentrelacement avancés sur les systèmes les moins performants. Voir la documentation vdpau.h pour plus de détails.
  • Correction de la procédure de décodage VDPAU VC-1 sur les plateformes 64-bit.
  • Mise à jour de librairie "VDPAU wrapper" pour permettre d’imprimer les messages "dlerror()" lors des problèmes de chargement.
  • Amélioration de la gestion par VDPAU sur certains GPU des flux H.264 corrompus et des flux MPEG corrompus/invalides.
  • Mise à jour de VDPAU pour permettre une meilleure gestion des options "range reduction" des fichiers WMV sur certains GPU. Une modification mineure de la rétrocompatibilité de l’API a été effectuée à cet effet : reportez-vous à la documentation vdpau.h pour plus d’informations sur "VdpPictureInfoVC1.rangered".
  • Correction d’un problème entraînant un marquage trop rapide des surfaces dans la file d’attente des présentations blit.
  • Mise à jour de VDPAU pour éviter certains problèmes de "display preemption" avec les trames de référence H.264 manquantes sur certains GPU.

Pour télécharger et installer les pilotes, respectez les étapes suivantes:

ÉTAPE 1: Lisez la licence des logiciels NVIDIA.

Vous devez accepter les clauses de ce contrat avant de télécharger tout fichier.

ÉTAPE 2: Téléchargez le pilote
Téléchargez le fichier  - NVIDIA-Linux-x86_64-180.44-pkg2.run

À l’intention des utilisateurs de SuSE : avant de télécharger le pilote, parcourez le programme d'installation de NVIDIA pour SuSE.

ÉTAPE 3: Procédez à l’installation
Saisissez « sh NVIDIA-Linux-x86_64-180.44-pkg2.run » pour installer le pilote, puis modifiez le fichier de configuration du serveur X en fonction de vos besoins. Consultez le fichier de texte README pour les instructions détaillées.

Pour toute question ou tout problème, consultez le forum de discussion Linux NVIDIA. Si vous n’y trouvez pas la solution à votre problème, adressez un e-mail (en anglais) à linux-bugs@nvidia.com.

Quand vous envoyez un e-mail à linux-bugs@nvidia.com veuillez y joindre un nvidia-bug-report.log que vous générerez en exécutant "nvidia-bug-report.sh".